This project is read-only.
3

Resolved

Hard coded URL for webservice locations?

description

Hi!
 
From what I can see there's a hardcoded url to "http://www.thoehler.com/webservices/ClientToolsMediaService.asmx" making it impossible to change the URL via the profiles settings?
 
I get this faultstring from the URLs http://www.thoehler.de/webservices/ClientToolsMaintenanceService.asmx:
<faultstring>
System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> ClientTools.Server.Webservices.Exceptions.IncorrectCredentialsException: Exception of type 'ClientTools.Server.Webservices.Exceptions.IncorrectCredentialsException' was thrown. at ClientTools.Server.Webservices.ClientToolsBaseService.Authenticate(String userName, String password, ServiceTypeEnum service) at ClientTools.Server.Webservices.ClientToolsMaintenanceService.GetLogInfos(String userName, String password) --- End of inner exception stack trace ---
</faultstring>
 
// ; ) Kalle

file attachments

comments

Kalpa wrote Apr 29, 2008 at 11:42 PM

And the media service is hardcoded to "http://www.thoehler.com/webservices/ClientToolsMediaService.asmx"...

I managed to get it to connect when I switched www.thoehler.com and www.thoehler.de to point to 127.0.0.1 (HOSTS-file edit via hostsman)

// ; ) Kalle

timgaunt wrote Jun 25, 2008 at 1:23 PM

Hmm I can't use the hostfile trick which is irritating.

Any idea of when this will be sorted?

wrote Jun 25, 2008 at 1:24 PM

wrote Jul 9, 2008 at 1:38 PM

agrath wrote Jul 22, 2008 at 2:33 AM

In:
ClientTools\ClientTools.Client.Library\Provider\WebserviceProvider.cs

wrote Jul 22, 2008 at 2:33 AM

hoehler wrote Dec 10, 2008 at 9:21 AM

Fixed in the new versions...

Sorry for the delay, I thought I would get emails when someone adds issues...

wrote Dec 10, 2008 at 9:22 AM

wrote Feb 13, 2013 at 9:14 PM

wrote May 16, 2013 at 2:24 AM

wrote May 16, 2013 at 2:24 AM

wrote Jun 14, 2013 at 8:24 AM